Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 03, 2026 - 21:00 CET
Scheduled
The Young Platform exchange will undergo maintenance on the 3rd of February, starting at 21:00 CEST and lasting approximately 2 hours. All trading activities will be suspended during this period; however, any transfers initiated during maintenance will be processed shortly after it concludes.
Please note that during this maintenance, the deposit addresses for DOT, XLM, ADA, KSM, SOL, NEAR, and ALGO will be updated. Users planning to deposit these currencies after the maintenance must use the new address displayed on the exchange.
Posted Jan 27, 2026 - 15:37 CET
This scheduled maintenance affected: Website (exchange.youngplatform.com), Mobile App (Young Platform), Advanced Trading Website (pro.youngplatform.com), Funding, Trading, and Api.